re = /(?:^(?=.*[a-z])|\G(?:.*?\b([A-Z]+)\b))/m
str = 'AB EF
a A 1 AB
ABC a
b ABCD a 1 ABCDE
AB EB '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end