using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<key>(\d{2}\w\d{3})<\/key>";
string input = @"Example: 10B329 or 11A465.
<key>10B329</key>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}