import re
regex = re.compile(r"<key>(\d{2}\w\d{3})<\/key>")
test_str = ("Example: 10B329 or 11A465.\n"
"<key>10B329</key>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")