re = /<key>(\d{2}\w\d{3})<\/key>/
str = 'Example: 10B329 or 11A465.
<key>10B329</key>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end