$re = '/<key>(\d{2}\w\d{3})<\/key>/';
$str = 'Example: 10B329 or 11A465.
<key>10B329</key>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);