package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<key>(\d{2}\w\d{3})<\/key>`)
var str = `Example: 10B329 or 11A465.
<key>10B329</key>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}