#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "test\{(a(?1)*b)\}"
Local $sString = "test{aaaaabbbbb}" & @CRLF & _
"test{aabb}" & @CRLF & _
"test{aaabbb}" & @CRLF & _
"test{aaabbbb}" & @CRLF & _
"test{aaaabbb}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")