$re = '/test\{(a(?1)*b)\}/';
$str = 'test{aaaaabbbbb}
test{aabb}
test{aaabbb}
test{aaabbbb}
test{aaaabbb}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);