re = /test\{(a(?1)*b)\}/
str = 'test{aaaaabbbbb}
test{aabb}
test{aaabbb}
test{aaabbbb}
test{aaaabbb}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end