package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`test\{(a(?1)*b)\}`)
var str = `test{aaaaabbbbb}
test{aabb}
test{aaabbb}
test{aaabbbb}
test{aaaabbb}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}