using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test\{(a(?1)*b)\}";
string input = @"test{aaaaabbbbb}
test{aabb}
test{aaabbb}
test{aaabbbb}
test{aaaabbb}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}