using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a[^>]* href="")(https:\/\/snaplogic\.test\/resources\?type=)([a-z]*)""";
string substitution = @"$1https://snaplogic.test/resources/$3";
string input = @"<a class=""test"" href=""http://dsdsdf.com"" target=""_blank"">
<a class=""test"" href=""https://snaplogic.test/resources?type=ebook"" target=""_blank"">
<a class=""testds"" href=""https://snaplogic.test/resources?type=video"">video resources</a> for some cool
<a class=""test"" href=""//dsdsdf.com"" target=""_blank"">
<a class=""test"" href=""http://dsdsdf.com"" target=""_blank"">
<a class=""test"" href=""https://www.snaplogic.com/"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}