use strict;
my $str = '<a class="test" href="http://dsdsdf.com" target="_blank">
<a class="test" href="https://snaplogic.test/resources?type=ebook" target="_blank">
<a class="testds" href="https://snaplogic.test/resources?type=video">video resources</a> for some cool
<a class="test" href="//dsdsdf.com" target="_blank">
<a class="test" href="http://dsdsdf.com" target="_blank">
<a class="test" href="https://www.snaplogic.com/">';
my $regex = qr/(<a[^>]* href=")(https:\/\/snaplogic\.test\/resources\?type=)([a-z]*)"/p;
my $subst = '$1https://snaplogic.test/resources/$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";