import re
regex = re.compile(r"(<a[^>]* href=\")(https:\/\/snaplogic\.test\/resources\?type=)([a-z]*)\"")
test_str = ("<a class=\"test\" href=\"http://dsdsdf.com\" target=\"_blank\">\n\n"
"<a class=\"test\" href=\"https://snaplogic.test/resources?type=ebook\" target=\"_blank\">\n\n"
"<a class=\"testds\" href=\"https://snaplogic.test/resources?type=video\">video resources</a> for some cool\n\n"
"<a class=\"test\" href=\"//dsdsdf.com\" target=\"_blank\">\n\n"
"<a class=\"test\" href=\"http://dsdsdf.com\" target=\"_blank\">\n\n"
"<a class=\"test\" href=\"https://www.snaplogic.com/\">")
subst = "$1https://snaplogic.test/resources/$3"
result = regex.sub(subst, test_str)
if result:
print(result)