package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a[^>]* href=")(https:\/\/snaplogic\.test\/resources\?type=)([a-z]*)"`)
var str = `<a class="test" href="http://dsdsdf.com" target="_blank">
<a class="test" href="https://snaplogic.test/resources?type=ebook" target="_blank">
<a class="testds" href="https://snaplogic.test/resources?type=video">video resources</a> for some cool
<a class="test" href="//dsdsdf.com" target="_blank">
<a class="test" href="http://dsdsdf.com" target="_blank">
<a class="test" href="https://www.snaplogic.com/">`
var substitution = "$1https://snaplogic.test/resources/$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}