re = /(<a[^>]* href=")(https:\/\/snaplogic\.test\/resources\?type=)([a-z]*)"/
str = '<a class="test" href="http://dsdsdf.com" target="_blank">
<a class="test" href="https://snaplogic.test/resources?type=ebook" target="_blank">
<a class="testds" href="https://snaplogic.test/resources?type=video">video resources</a> for some cool
<a class="test" href="//dsdsdf.com" target="_blank">
<a class="test" href="http://dsdsdf.com" target="_blank">
<a class="test" href="https://www.snaplogic.com/">'
subst = '$1https://snaplogic.test/resources/$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result