# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\b[a-z]{1,}\b).*?)(\b\2\b)(.*)$/\1and\4/gmix;t' <<< "Green shirt green hat
Green shirt greenish hat
You are an artistically gifted musically gifted individual"