import re
regex = re.compile(r"""
((\b[a-z]{1,}\b).*?)(\b\2\b)(.*)$
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("Green shirt green hat\n"
"Green shirt greenish hat\n"
"You are an artistically gifted musically gifted individual")
subst = "\\1and\\4"
result = regex.sub(subst, test_str)
if result:
print(result)