use strict;
my $str = 'Green shirt green hat
Green shirt greenish hat
You are an artistically gifted musically gifted individual';
my $regex = qr/((\b[a-z]{1,}\b).*?)(\b\2\b)(.*)$/mixp;
my $subst = '\\1and\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";