using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"BBB((?:B(?:B(?:[^B])|[^B])|[^B])*?)EEE";
string input = @"BBB foo BBB bar EEE
BBB bar EEE baz EEE
BBB foo BBB bar EEE baz EEE
BBBB EEEE
BBBBB EEEE
BBBBBB EEEE
BBBB EEEEE
BBBBB EEEEE
BBBBBB EEEEE
BBBB EEEEEE
BBBBB EEEEEE
BBBBBB EEEEEE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}