package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)BBB((?:B(?:B(?:[^B])|[^B])|[^B])*?)EEE`)
var str = `BBB foo BBB bar EEE
BBB bar EEE baz EEE
BBB foo BBB bar EEE baz EEE
BBBB EEEE
BBBBB EEEE
BBBBBB EEEE
BBBB EEEEE
BBBBB EEEEE
BBBBBB EEEEE
BBBB EEEEEE
BBBBB EEEEEE
BBBBBB EEEEEE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}