import Foundation
let pattern = #"BBB((?:B(?:B(?:[^B])|[^B])|[^B])*?)EEE"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
BBB foo BBB bar EEE
BBB bar EEE baz EEE
BBB foo BBB bar EEE baz EEE
BBBB EEEE
BBBBB EEEE
BBBBBB EEEE
BBBB EEEEE
BBBBB EEEEE
BBBBBB EEEEE
BBBB EEEEEE
BBBBB EEEEEE
BBBBBB EEEEEE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)