re = /BBB((?:B(?:B(?:[^B])|[^B])|[^B])*?)EEE/m
str = 'BBB foo BBB bar EEE
BBB bar EEE baz EEE
BBB foo BBB bar EEE baz EEE
BBBB EEEE
BBBBB EEEE
BBBBBB EEEE
BBBB EEEEE
BBBBB EEEEE
BBBBBB EEEEE
BBBB EEEEEE
BBBBB EEEEEE
BBBBBB EEEEEE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end