#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(?s:START.*?END)|\/\/.*|\.\s*\w+\b)(*SKIP)(*F)|old"
Local $sString = "__DATA__" & @CRLF & _
"xx START xx old xx END xx --> ignore" & @CRLF & _
"xx old xx --> REPLACE !" & @CRLF & _
"START xx old --> ignore" & @CRLF & _
" xx old xx END --> ignore" & @CRLF & _
" xx old xx --> REPLACE !" & @CRLF & _
"// xx old --> ignore" & @CRLF & _
"xx // xx old --> ignore" & @CRLF & _
"xx . old old xx --> ignore first one, replace second one" & @CRLF & _
"." & @CRLF & _
" old --> ignore" & @CRLF & _
" (old) xx --> REPLACE !" & @CRLF & _
"xx old xx --> REPLACE !"
Local $sSubst = "new"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)