const regex = /(?:(?s:START.*?END)|\/\/.*|\.\s*\w+\b)(*SKIP)(*F)|old/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?s:START.*?END)|\\\/\\\/.*|\\.\\s*\\w+\\b)(*SKIP)(*F)|old', 'g')
const str = `__DATA__
xx START xx old xx END xx --> ignore
xx old xx --> REPLACE !
START xx old --> ignore
xx old xx END --> ignore
xx old xx --> REPLACE !
// xx old --> ignore
xx // xx old --> ignore
xx . old old xx --> ignore first one, replace second one
.
old --> ignore
(old) xx --> REPLACE !
xx old xx --> REPLACE !`;
const subst = `new`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);