#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=value\=")(?:[^"\\<]|\\"|\\\\|\\<)++(?=")"
Local $sString = "<message>" & @CRLF & _
" <set name=" value=" />" & @CRLF & _
" <set name=".." value="garbled string" type="name" />" & @CRLF & _
" <set age=".." value="32" />" & @CRLF & _
" <set something=".." value="value=\"\"\"\"" />" & @CRLF & _
" .." & @CRLF & _
"</message>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")