$re = '/(?<=value\=")(?:[^"\\\\<]|\\\\"|\\\\\\\\|\\\\<)++(?=")/';
$str = '<message>
<set name=" value=" />
<set name=".." value="garbled string" type="name" />
<set age=".." value="32" />
<set something=".." value="value=\\"\\"\\"\\"" />
..
</message>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);