import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=value\\=\")(?:[^\"\\\\<]|\\\\\"|\\\\\\\\|\\\\<)++(?=\")";
final String string = "<message>\n"
+ " <set name=\" value=\" />\n"
+ " <set name=\"..\" value=\"garbled string\" type=\"name\" />\n"
+ " <set age=\"..\" value=\"32\" />\n"
+ " <set something=\"..\" value=\"value=\\\"\\\"\\\"\\\"\" />\n"
+ " ..\n"
+ "</message>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}