const regex = /(?<=value\=")(?:[^"\\<]|\\"|\\\\|\\<)++(?=")/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=value\\=")(?:[^"\\\\<]|\\\\"|\\\\\\\\|\\\\<)++(?=")', '')
const str = `<message>
<set name=" value=" />
<set name=".." value="garbled string" type="name" />
<set age=".." value="32" />
<set something=".." value="value=\\"\\"\\"\\"" />
..
</message>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}