re = /(?<=value\=")(?:[^"\\<]|\\"|\\\\|\\<)++(?=")/
str = '<message>
<set name=" value=" />
<set name=".." value="garbled string" type="name" />
<set age=".." value="32" />
<set something=".." value="value=\\"\\"\\"\\"" />
..
</message>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end