const regex = /(<br\s*/?>)|[^A-Za-z0-9.,'-]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<br\\s*\/?>)|[^A-Za-z0-9.,\'-]', 'g')
const str = `<br>Text-here !<br />`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);