import re
regex = re.compile(r"(<br\s*/?>)|[^A-Za-z0-9.,'-]")
test_str = "<br>Text-here !<br />"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)