$re = '/(<br\s*/?>)|[^A-Za-z0-9.,\'-]/';
$str = '<br>Text-here !<br />';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;