re = /(<br\s*\/?>)|[^A-Za-z0-9.,'-]/
str = '<br>Text-here !<br />'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result