using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*video\.cnbc\.com)";
string input = @"video.cnbc.com/id/33333
cnbc.com/id/34243424234
video.cnbc.com/id/wer423424";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}