import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*video\\.cnbc\\.com)";
final String string = "video.cnbc.com/id/33333\n\n\n"
+ "cnbc.com/id/34243424234\n\n\n"
+ "video.cnbc.com/id/wer423424";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}