import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[@|#](.*?)\\s";
final String string = "Hi this is a test @info@test.com and @martin we have to go.\n"
+ "@info@test.com , do not enter.\n"
+ "Look at #ean-4456 is not valid, please verify #ean-2245 to do this.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}