re = /[@|#](.*?)\s/m
str = 'Hi this is a test @info@test.com and @martin we have to go.
@info@test.com , do not enter.
Look at #ean-4456 is not valid, please verify #ean-2245 to do this.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end