// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[@|#](.*?)\s").unwrap();
let string = "Hi this is a test @info@test.com and @martin we have to go.
@info@test.com , do not enter.
Look at #ean-4456 is not valid, please verify #ean-2245 to do this.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}