$re = '/[@|#](.*?)\s/m';
$str = 'Hi this is a test @info@test.com and @martin we have to go.
@info@test.com , do not enter.
Look at #ean-4456 is not valid, please verify #ean-2245 to do this.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);