import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w\\s-\\(\\)]+)</";
final String string = "<a class=\"producto\" href=\"ver.asp?id=4013\">A86028</a></span><!-- /a --></td></tr>\n"
+ " <a class=\"producto\" href=\"ver.asp?id=4014\">1027C</a></span><!-- /a --></td></tr>\n"
+ " <a class=\"producto\" href=\"ver.asp?id=4014\">5611 4020</a></span>\n"
+ "<!-- /a --></td></tr>\n"
+ " <a class=\"producto\" href=\"ver.asp?id=4014\">396-4185</a></span>\n"
+ "<!-- /a --></td></tr>\n"
+ " <a class=\"producto\" href=\"ver.asp?id=4014\">834006-5-7</a></span>\n"
+ "<!-- /a --></td></tr>\n"
+ " <a class=\"producto\" href=\"ver.asp?id=4014\">5601GR 4325GR</a></span>\n"
+ "<!-- /a --></td></tr>\n"
+ " <a class=\"producto\" href=\"ver.asp?id=4014\">2182CR(2)</a></span>\n"
+ "<!-- /a --></td></tr>\n"
+ " <a class=\"producto\" href=\"ver.asp?id=4014\">1458-54-63-55</a></span>\n"
+ "<!-- /a --></td></tr>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}