// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\w\s-\(\)]+)</").unwrap();
let string = "<a class=\"producto\" href=\"ver.asp?id=4013\">A86028</a></span><!-- /a --></td></tr>
<a class=\"producto\" href=\"ver.asp?id=4014\">1027C</a></span><!-- /a --></td></tr>
<a class=\"producto\" href=\"ver.asp?id=4014\">5611 4020</a></span>
<!-- /a --></td></tr>
<a class=\"producto\" href=\"ver.asp?id=4014\">396-4185</a></span>
<!-- /a --></td></tr>
<a class=\"producto\" href=\"ver.asp?id=4014\">834006-5-7</a></span>
<!-- /a --></td></tr>
<a class=\"producto\" href=\"ver.asp?id=4014\">5601GR 4325GR</a></span>
<!-- /a --></td></tr>
<a class=\"producto\" href=\"ver.asp?id=4014\">2182CR(2)</a></span>
<!-- /a --></td></tr>
<a class=\"producto\" href=\"ver.asp?id=4014\">1458-54-63-55</a></span>
<!-- /a --></td></tr>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}