const regex = /([\w\s-\(\)]+)<//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w\\s-\\(\\)]+)<\/', 'g')
const str = `<a class="producto" href="ver.asp?id=4013">A86028</a></span><!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">1027C</a></span><!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">5611 4020</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">396-4185</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">834006-5-7</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">5601GR 4325GR</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">2182CR(2)</a></span>
<!-- /a --></td></tr>
<a class="producto" href="ver.asp?id=4014">1458-54-63-55</a></span>
<!-- /a --></td></tr>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}