using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(url=https://www\.translatum\.gr.*?)\[/url]";
string substitution = @"[i\1[/iurl]";
string input = @"Test aetejklkj fa jklkj dsdfs [url=https://www.translatum.gr/forum/index.php?topic=989146.0]telerobotically -> τηλερομποτικά, τηλερομποτικώς[/url] fskjlkj
Gfdsklkj fjgkjkl klkjdass
[url=https://www.in.gr/]in.gr | Όλες οι ειδήσεις - Ολοκληρωμένη κάλυψη ειδήσεων[/url] Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass
Gfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdass ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}