// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(url=https://www\.translatum\.gr.*?)\[/url]").unwrap();
let string = "Test aetejklkj fa jklkj dsdfs [url=https://www.translatum.gr/forum/index.php?topic=989146.0]telerobotically -> τηλερομποτικά, τηλερομποτικώς[/url] fskjlkj
Gfdsklkj fjgkjkl klkjdass
[url=https://www.in.gr/]in.gr | Όλες οι ειδήσεις - Ολοκληρωμένη κάλυψη ειδήσεων[/url] Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass
Gfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdass ";
let substitution = "[i\\1[/iurl]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}