const regex = new RegExp('\\[(url=https://www\\.translatum\\.gr.*?)\\[/url]', 'gm')
const str = `Test aetejklkj fa jklkj dsdfs [url=https://www.translatum.gr/forum/index.php?topic=989146.0]telerobotically -> τηλερομποτικά, τηλερομποτικώς[/url] fskjlkj
Gfdsklkj fjgkjkl klkjdass
[url=https://www.in.gr/]in.gr | Όλες οι ειδήσεις - Ολοκληρωμένη κάλυψη ειδήσεων[/url] Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass
Gfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdass `;
const subst = `[i\1[/iurl]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);