import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(url=https://www\\.translatum\\.gr.*?)\\[/url]";
final String string = "Test aetejklkj fa jklkj dsdfs [url=https://www.translatum.gr/forum/index.php?topic=989146.0]telerobotically -> τηλερομποτικά, τηλερομποτικώς[/url] fskjlkj \n"
+ "Gfdsklkj fjgkjkl klkjdass\n\n"
+ "[url=https://www.in.gr/]in.gr | Όλες οι ειδήσεις - Ολοκληρωμένη κάλυψη ειδήσεων[/url] Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdass\n\n"
+ "Gfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdass Gfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdassGfdsklkj fjgkjkl klkjdass ";
final String subst = "[i\\1[/iurl]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}