package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<lc>(?=[^a-z\n]*[a-z])) # lowercase
(?<uc>(?=[^A-Z\n]*[A-Z])) # uppercase
(?<digit>(?=[^\d\n]*\d)) # digit
(?<special>(?=.*[!@]+)) # special character
)
^(?&lc)(?&uc)(?&digit)(?&special).{6,}$`)
var str = `ABC123!s
testman
weakpassword
Lmnttmotm1406!
Ab1!!!!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}