re = /(?(DEFINE)
(?<lc>(?=[^a-z\n]*[a-z])) # lowercase
(?<uc>(?=[^A-Z\n]*[A-Z])) # uppercase
(?<digit>(?=[^\d\n]*\d)) # digit
(?<special>(?=.*[!@]+)) # special character
)
^(?&lc)(?&uc)(?&digit)(?&special).{6,}$/mx
str = 'ABC123!s
testman
weakpassword
Lmnttmotm1406!
Ab1!!!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end