import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<lc>(?=[^a-z\\n]*[a-z])) # lowercase\n"
+ " (?<uc>(?=[^A-Z\\n]*[A-Z])) # uppercase\n"
+ " (?<digit>(?=[^\\d\\n]*\\d)) # digit\n"
+ " (?<special>(?=.*[!@]+)) # special character\n"
+ ")\n"
+ "^(?&lc)(?&uc)(?&digit)(?&special).{6,}$";
final String string = "ABC123!s\n"
+ "testman\n"
+ "weakpassword\n"
+ "Lmnttmotm1406!\n"
+ "Ab1!!!!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}